Community
Message Board

Chat room - users
Game Over
( 394431 downloads)
Work In Progress
( 523201 downloads)
Links

Code Exchange
Downloads
Tutorials
Add to Favourites

Submit news

DIV ARENA FORUMS
Not logged in [Login - Register]
Go To Bottom

Printable Version  
 Pages:  1  
Author: Subject: anyone running DIV on ubuntu?
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 02:46 PM
anyone running DIV on ubuntu?


Help!
I've been trying to get DIV running on Ubuntu. No luck so far.
When I try to run d-linux nothing happens, not even an error.
Is there anything obvious that I might be missing?
View user's profile View All Posts By User
MikeDX
DIV Nerd
*********


Avatar


Posts: 8388607
Registered: 25-2-2016
Member Is Offline


[*] posted on 4-3-2016 at 02:49 PM


you probably need to install some packages

Code:
sudo apt-get install libsdl1.2-mixer libsdl1.2-debian


should do the trick

DIV is developed on debian so this should not be an issue :)
View user's profile View All Posts By User
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:02 PM


That was quick. Thanks
View user's profile View All Posts By User
MikeDX
DIV Nerd
*********


Avatar


Posts: 8388607
Registered: 25-2-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:03 PM


I should really package it up into a .deb file but haven't got around to it yet.

Did installing those libs help?
View user's profile View All Posts By User
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:06 PM


I'll let you know in a jiffy
View user's profile View All Posts By User
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:17 PM


Didn't work. Here's what I got when I tried to install:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libsdl1.2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package libsdl1.2-mixer
E: Couldn't find any package by regex 'libsdl1.2-mixer'
E: Package 'libsdl1.2' has no installation candidate
E: Unable to locate package debian

View user's profile View All Posts By User
MikeDX
DIV Nerd
*********


Avatar


Posts: 8388607
Registered: 25-2-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:27 PM


Quote: Originally posted by dom cook  
Didn't work. Here's what I got when I tried to install:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libsdl1.2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package libsdl1.2-mixer
E: Couldn't find any package by regex 'libsdl1.2-mixer'
E: Package 'libsdl1.2' has no installation candidate
E: Unable to locate package debian



I think we both got this wrong.

The correct mixer package is libsdl-mixer1.2
the correct libsdl package is libsdl1.2-debian (not libsdl1.2 debian)


Code:
sudo apt-get install libsdl-mixer1.2 libsdl1.2-debian


try that :)
View user's profile View All Posts By User
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:33 PM


will do.
I was trying this when I saw your last post

sudo apt-get install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev

It took a while but it seems to have got DIV running.

I'll try your one now just for good measure.
View user's profile View All Posts By User
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:37 PM


I tried :

sudo apt-get install libsdl-mixer1.2 libsdl1.2-debian

I got:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libsdl1.2-debian
E: Couldn't find any package by regex 'libsdl1.2-debian'

But all that other shtuff seemed to do the trick. Nice teamwork.
View user's profile View All Posts By User
dom cook
Div Pro
******




Posts: 386
Registered: 4-3-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:45 PM


By the way. I forgot to say. Thanks a million for resurrecting DIV. I might never manage to produce anything with it but simply knowing it's there is so reassuring.
View user's profile View All Posts By User
MikeDX
DIV Nerd
*********


Avatar


Posts: 8388607
Registered: 25-2-2016
Member Is Offline


[*] posted on 4-3-2016 at 03:52 PM


Looks like you've installed the dev packages of SDL - not really needed for this but as long as you're up and running that's the main thing :) I believe if you install libsdl-mixer1.2 package it should pull (whatever libsdl1.2 is on your system) in as a dependancy.

Thanks for your support. You might produce something amazing - plenty of our users have gone on to have VERY successful programming careers after starting with DIV :)
View user's profile View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 2-11-2016 at 11:06 AM


Hi,

I've installed libsdl-mixer1.2 libsdl-net1.2 libsdl1.2debian and I managed to run Div on Ubuntu Linux but when trying to run a Game I get the following error:

/divrun-LINUX: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.22' not found (required by ./divrun-LINUX)

Am I missing any other libraries? Perhaps lib-gcc? I get this issue at last nightly build

Thanks!




JosepGames
View user's profile Visit user's homepage View All Posts By User
CicTec
DIV Pro
******




Posts: 453
Registered: 6-8-2016
Member Is Offline


[*] posted on 2-11-2016 at 11:52 AM


Hola josepgames,

Necesitas instalar el paquete de glibc 2.22 o superior, parece que tu SO no la contiene, puedes encontrala aqui:
https://www.gnu.org/software/libc/

Aunque lo mejor es que bajes el paquete directamente del Ubuntu Center o shell.

----------------------------------------------------------------------------------------------------------------------------------------------
Hello josepgames,

Need to install the glibc 2.22 o greater, seems that your SO don't have this, you can download from:
https://www.gnu.org/software/libc/

However, the best option is to install it via the Ubuntu Center or shell.


[Edited on 2-11-2016 by CicTec]
View user's profile View All Posts By User
MikeDX
DIV Nerd
*********


Avatar


Posts: 8388607
Registered: 25-2-2016
Member Is Offline


[*] posted on 2-11-2016 at 11:55 AM


That's really strange. I develop DIV on ubunutu. It should work

Also it's odd it is complaining about divrun-LINUX as that's never usually ran directly,

If the ide runs the games should run - although they should run with divdbg-LINUX so that's even more confusing as to what's happening
View user's profile View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 2-11-2016 at 12:34 PM


Thanks for your replies.
From Div Studio i get the following error:

system/divdbg-LINUX: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.22' not found (required by system/divdbg-LINUX)




JosepGames
View user's profile Visit user's homepage View All Posts By User
CicTec
DIV Pro
******




Posts: 453
Registered: 6-8-2016
Member Is Offline


[*] posted on 2-11-2016 at 12:38 PM


Parece que falte la libc como indique anteriormente, intenta instalarla y ver si soluciona el problema.
----------------------------------------------------------------------------------------------------------------
It's seems lacking the glibc as mentioned before, try to install it and see if it solves the problem.
View user's profile View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 2-11-2016 at 01:00 PM


Hi,

I've tryied installing version 2.24 for this .deb

https://packages.debian.org/sid/amd64/libc6-udeb/download

But still raises the same error. It seems 2.22 is required and can't be a higher version...

Which version of ubuntu are you running?

Thanks




JosepGames
View user's profile Visit user's homepage View All Posts By User
CicTec
DIV Pro
******




Posts: 453
Registered: 6-8-2016
Member Is Offline


[*] posted on 2-11-2016 at 01:06 PM


Ok, entonces es posible que haya incompatibilidades entre las 2 versiones y la libreria usada y necesaria para DIV sebe ser la 2.22, espera que Mike pueda revisionar el asunto.

Yo la he probado son el Windows y ahi funciona todo bien.

------------------------------------------------------------------------------------------------------------------------------------------------------ --

Ok, then it is possible that there is some incompatibility between the two versions of the library used and necessary for the DIV should be 2.22, expect that Mike can view the theme.

I tried it only in windows and it works fine there.
View user's profile View All Posts By User
CicTec
DIV Pro
******




Posts: 453
Registered: 6-8-2016
Member Is Offline


[*] posted on 2-11-2016 at 01:11 PM


En alternativa, desinstala la 2.24 y prueba a instalar exactamente la 2.22.

--------------------------------------------------------------------------------------

Alternatively, try uninstalling the 2.24 and installs exactly 2.22.
View user's profile View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 3-11-2016 at 03:29 PM


I cannot find version 2.22 :fake sniffle:



JosepGames
View user's profile Visit user's homepage View All Posts By User
CicTec
DIV Pro
******




Posts: 453
Registered: 6-8-2016
Member Is Offline


[*] posted on 4-11-2016 at 09:51 AM


Mmmm ok, I have no other ideas at moment, maybe Mike discovers the cause of the problem.
View user's profile View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 4-11-2016 at 10:08 AM


For the ones who managed running Div DX under Ubuntu, could you tell me which version are you running?

Thanks




JosepGames
View user's profile Visit user's homepage View All Posts By User
MikeDX
DIV Nerd
*********


Avatar


Posts: 8388607
Registered: 25-2-2016
Member Is Offline


[*] posted on 4-11-2016 at 10:44 AM


I run ubuntu 16.04 at home and debian stretch/squeeze on the server.

What version are you running?

View user's profile View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 4-11-2016 at 11:17 AM


I was trying with Ubuntu 14.04 I'll try on 16.04



JosepGames
View user's profile Visit user's homepage View All Posts By User
josepgames
Loyalty card holder
******


Avatar


Posts: 66
Registered: 31-10-2016
Location: Barcelona - Spain
Member Is Offline

Mood: Happy

[*] posted on 4-11-2016 at 06:42 PM


On ubuntu 16.04 works fine, but does not find files at proper directories. When I load an fpg or map file, for instance, even having prg file at root folder (where there are subfolders for each extonsion), states file not found. Same situation works fine with windows version. Any clue?




JosepGames
View user's profile Visit user's homepage View All Posts By User
 Pages:  1  

  Go To Top

Powered by XMB
XMB Forum Software © 2001-2012 The XMB Group
[Queries: 18]